swconfig: support providing the switch device name in an option instead of the sectio...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jan 2010 00:38:04 +0000 (00:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jan 2010 00:38:04 +0000 (00:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19208 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/swconfig/Makefile
package/swconfig/files/switch.sh
package/swconfig/src/uci.c

index a7bed73..72af8c7 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=swconfig
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
index 7078b2e..18d5fbd 100644 (file)
@@ -2,8 +2,10 @@
 # Copyright (C) 2009 OpenWrt.org
 
 setup_switch_dev() {
-       ifconfig "$1" 0.0.0.0
-       swconfig dev "$1" load network
+       config_get name "$1" name
+       name="${name:-$1}"
+       [ -d "/sys/class/net/$name" ] && ifconfig "$name" up
+       swconfig dev "$name" load network
 }
 
 setup_switch() {
index 2df837d..e597ace 100644 (file)
@@ -107,6 +107,7 @@ int swlib_apply_from_uci(struct switch_dev *dev, struct uci_package *p)
        struct uci_element *e;
        struct uci_section *s;
        struct uci_option *o;
+       struct uci_ptr ptr;
        struct switch_val val;
        int i;
 
@@ -114,11 +115,28 @@ int swlib_apply_from_uci(struct switch_dev *dev, struct uci_package *p)
        head = &settings;
 
        uci_foreach_element(&p->sections, e) {
+               struct uci_element *n;
+
                s = uci_to_section(e);
 
                if (strcmp(s->type, "switch") != 0)
                        continue;
 
+               uci_foreach_element(&s->options, n) {
+                       struct uci_option *o = uci_to_option(n);
+
+                       if (strcmp(n->name, "name") != 0)
+                               continue;
+
+                       if (o->type != UCI_TYPE_STRING)
+                               continue;
+
+                       if (!strcmp(o->v.string, dev->dev_name))
+                               goto found;
+
+                       break;
+               }
+
                if (strcmp(e->name, dev->dev_name) != 0)
                        continue;