luci-0.9: merge r4843, r4844
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 15 Jun 2009 19:21:36 +0000 (19:21 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 15 Jun 2009 19:21:36 +0000 (19:21 +0000)
contrib/package/cyassl-luci/Makefile
libs/nixio/src/splice.c

index 53b319b..6d1b6a6 100644 (file)
@@ -37,9 +37,9 @@ define Package/libcyassl-luci/description
        CyaSSL is an SSL library optimized for small footprint, both on disk and for memory use.
 endef
 
-TARGET_CFLAGS += $(FPIC) -DTFM_NO_ASM
+TARGET_CFLAGS += $(FPIC)
 
-CONFIGURE_ARGS += --without-zlib --enable-fastmath
+CONFIGURE_ARGS += --without-zlib
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/ctaocrypt
index db215ef..0704dfd 100644 (file)
@@ -59,6 +59,15 @@ ssize_t splice(int __fdin, __off64_t *__offin, int __fdout,
        return -1;
 #endif
 }
+
+#undef SPLICE_F_MOVE
+#undef SPLICE_F_NONBLOCK
+#undef SPLICE_F_MORE
+
+#define SPLICE_F_MOVE 1
+#define SPLICE_F_NONBLOCK 2
+#define SPLICE_F_MORE 4
+
 #endif /* __UCLIBC__ */
 
 /**