ipq806x: fix R7500 kernel generation
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Sep 2015 10:09:26 +0000 (10:09 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Sep 2015 10:09:26 +0000 (10:09 +0000)
Obviously the dummy rootfs must be after the kernel (uImage), not
included in it.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46837 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ipq806x/image/Makefile

index 316e0d3..c59e6d4 100644 (file)
@@ -74,7 +74,7 @@ define Device/DniImage
        FILESYSTEMS := squashfs
        KERNEL_SUFFIX := -uImage
        KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
-       KERNEL = kernel-bin | append-dtb | pad-to $$$$(($$(KERNEL_SIZE)-2*64-1)) | append-file $(KDIR)/root.dummy | uImage none
+       KERNEL = kernel-bin | append-dtb | pad-to $$$$(($$(KERNEL_SIZE)-2*64-1)) | uImage none | append-file $(KDIR)/root.dummy
        KERNEL_NAME := zImage
        NETGEAR_BOARD_ID :=
        NETGEAR_HW_ID :=