Missing patch from previous commit...
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Oct 2008 15:51:35 +0000 (15:51 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Oct 2008 15:51:35 +0000 (15:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12823 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/python/patches/070-dont-clean-ipkg-install.patch [new file with mode: 0644]

diff --git a/lang/python/patches/070-dont-clean-ipkg-install.patch b/lang/python/patches/070-dont-clean-ipkg-install.patch
new file mode 100644 (file)
index 0000000..0eb04bb
--- /dev/null
@@ -0,0 +1,17 @@
+--- Python-2.5.1/Makefile.pre.in.orig  2008-10-02 12:30:28.000000000 +0200
++++ Python-2.5.1/Makefile.pre.in       2008-10-02 12:31:50.000000000 +0200
+@@ -996,11 +996,11 @@
+ # Sanitation targets -- clean leaves libraries, executables and tags
+ # files, which clobber removes those as well
+ pycremoval:
+-      find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
++      find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
+ clean: pycremoval
+-      find . -name '*.o' -exec rm -f {} ';'
+-      find . -name '*.s[ol]' -exec rm -f {} ';'
++      find . ! -path './ipkg-install/*' -name '*.o' -exec rm -f {} ';'
++      find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
+       find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
+       find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true