Fix nagios compilation
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 13:38:00 +0000 (13:38 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 13:38:00 +0000 (13:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8628 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/nagios/Makefile

index 01fef8d..f5b4ace 100644 (file)
@@ -35,10 +35,13 @@ define Package/send-nagios/conffiles
 /etc/send_nagios.cfg
 endef
 
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+
 define Build/Configure
        $(call Build/Configure/Default,\
                --with-nagios-user="root" \
                --with-nagios-group="root", \
+               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
                LIBS="-lnotimpl" \
        )
 endef