[packages] libshout: depend on both libvorbis and libvorbisidec (#8496)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Dec 2010 10:08:10 +0000 (10:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Dec 2010 10:08:10 +0000 (10:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24792 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libshout/Makefile

index 9067d17..1072e91 100644 (file)
@@ -24,7 +24,7 @@ TARGET_CFLAGS += $(FPIC)
 
 define Package/libshout
   SECTION:=libs
-  DEPENDS:= +libspeex +libtheora +libvorbis
+  DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec
   CATEGORY:=Libraries
   TITLE:=Library which can be used to write a source client like ices
   URL:=http://www.icecast.org/download.php
@@ -41,7 +41,7 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
-               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis" \
+               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
                --enable-shared \
                --enable-static \
        )