[packages] ez-ipupdate: use network.sh to find device names
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 May 2012 15:08:19 +0000 (15:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 May 2012 15:08:19 +0000 (15:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31944 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ez-ipupdate/Makefile
net/ez-ipupdate/files/ez-ipupdate.hotplug

index 90a97e0..5a5b890 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ez-ipupdate
 PKG_VERSION:=3.0.11b8
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
index f07542f..3359c6a 100644 (file)
@@ -16,7 +16,7 @@ case "$ACTION" in
            [ "$program" = "$NAME" ] && {
                config_get interface $cfg interface
                [ "$interface" = "$INTERFACE" ] && {
-                   config_get dev "$INTERFACE" ifname
+                   network_get_device dev "$INTERFACE" || return
 
                    config_get enabled $cfg enabled
                    enabled=${enabled:-1}
@@ -73,11 +73,9 @@ EOF
            }
        }
 
+       . /lib/functions/network.sh
 
-       include /lib/network
-       scan_interfaces
        config_load ddns
-
        config_foreach ddns ddns
        ;;
 esac