include: unbreak conffiles, postinst & prerm exports
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Oct 2014 09:24:51 +0000 (09:24 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Oct 2014 09:24:51 +0000 (09:24 +0000)
Changeset r43017 reworked the ipkg control metadata generation but broke
the export of conffiles, postinst and prerm defines.

Change the code back to rely on shvar and shexport, this is required to
properly output multiline contents.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43041 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 13bb7c7..77eaeb8 100644 (file)
@@ -13,10 +13,14 @@ IPKG_BUILD:= \
 
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
+# 1: package name
+# 2: variable name
+# 3: variable suffix
 define BuildIPKGVariable
 ifdef Package/$(1)/$(2)
   $$(IPKG_$(1)) : VAR_$(2)$(3)=$$(Package/$(1)/$(2))
-  $(1)_COMMANDS += echo "$$$$$(2)$(3)" > $(2)$(3);
+  $(call shexport,Package/$(1)/$(2))
+  $(1)_COMMANDS += echo "$$$$$$$$$(call shvar,Package/$(1)/$(2))" > $(2)$(3);
 endif
 endef