libowfat: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Jun 2014 16:26:43 +0000 (16:26 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Jun 2014 16:26:43 +0000 (16:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41183 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libowfat/Makefile [deleted file]

diff --git a/libs/libowfat/Makefile b/libs/libowfat/Makefile
deleted file mode 100644 (file)
index 2741f49..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-# Copyright (C) 2010-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-LOWFAT_VERSION=0.28
-
-PKG_NAME:=libowfat
-PKG_VERSION:=$(LOWFAT_VERSION)
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dl.fefe.de
-PKG_MD5SUM:=6bbee9a86506419657d87123b7a6f2c1
-
-include $(INCLUDE_DIR)/package.mk
-
-# set to 1 to enable debugging
-DEBUG=
-
-define Package/libowfat
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=reimplemented libdjb under GPL
-  URL:=http://www.fefe.de/libowfat/
-endef
-
-define Build/Configure
-endef
-
-TARGET_CFLAGS += $(FPIC)
-LOWFAT_MAKEOPTS = $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
-       DEBUG="$(DEBUG)" \
-       VERSION="$(LOWFAT_VERSION)" \
-       OS="Linux"
-
-# work around a nasty gcc bug
-ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
-  LOWFAT_MAKEOPTS += WOPTS=""
-endif
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(LOWFAT_MAKEOPTS)
-endef
-
-define Build/InstallDev
-       mkdir -p $(1)/usr/include/libowfat
-       $(CP) $(PKG_BUILD_DIR)/*.h $(1)/usr/include/libowfat
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/*.a $(1)/usr/lib
-endef
-
-$(eval $(call BuildPackage,libowfat))