net/freeswitch: Change -upstream-defaults and -minimal to use mod_syslog instead...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jun 2010 13:36:27 +0000 (13:36 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jun 2010 13:36:27 +0000 (13:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21965 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/freeswitch/Makefile
net/freeswitch/files/freeswitch.init

index e3da8a0..a2123b5 100644 (file)
@@ -164,7 +164,7 @@ $(call Package/freeswitch/Default)
   DEPENDS:= freeswitch \
                +freeswitch-mod-commands \
                +freeswitch-mod-conference \
-               +freeswitch-mod-console \
+               +freeswitch-mod-syslog \
                +freeswitch-mod-curl \
                +freeswitch-mod-dialplan-xml \
                +freeswitch-mod-dptools \
@@ -193,7 +193,7 @@ $(call Package/freeswitch/Default)
   TITLE:=FreeSWITCH minimal config
   DEPENDS:= freeswitch \
                +freeswitch-mod-commands \
-               +freeswitch-mod-console \
+               +freeswitch-mod-syslog \
                +freeswitch-mod-dialplan-xml \
                +freeswitch-mod-dptools \
                +freeswitch-mod-event-socket \
@@ -349,6 +349,8 @@ define Build/Compile
                DESTDIR="$(PKG_INSTALL_DIR)" \
                LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
                all $(MAKE_INSTALL_TARGETS)
+       $(SED) 's|^\([:blank:]*\)\(.*\)"mod_console"\(.*\)$$$$|\1<!-- \2"mod_console"\3 -->|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
+       $(SED) 's|^\([:blank:]*\)<!-- \(.*\)"mod_syslog"\(.*\) -->\(.*\)$$$$|\1\2"mod_syslog"\3\4 -->|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
 endef
 
 define Build/InstallDev
index a155724..8637556 100644 (file)
@@ -15,7 +15,7 @@ start() {
        mkdir -p $FS_DIR_DB
        mkdir -p $FS_DIR_LOG
        ulimit -s 240
-       $FS_DIR/usr/bin/freeswitch $OPTIONS -c &
+       $FS_DIR/usr/bin/freeswitch $OPTIONS -nc
 }
 
 stop() {
@@ -35,3 +35,4 @@ restart() {
        sleep 10
        start
 }
+