Update socat to 1.6.0.1 (#3654)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 11:27:01 +0000 (11:27 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 11:27:01 +0000 (11:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11685 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/socat/Makefile
net/socat/patches/501-honor_ldflags.patch
net/socat/patches/502-no_sslv2.patch

index 2274648..22b3aae 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=socat
-PKG_VERSION:=1.4.3.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.6.0.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
-PKG_MD5SUM:=ce574e75c2fda4456e8efd4efb86ec5e
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=6a0dd33cde2a18eb382433aca8f76ce2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,11 +27,11 @@ define Package/socat
 endef
 
 define Package/socat/description
-       SoCat (for SOcket CAT) establishes two bidirectional byte streams and 
+       SoCat (for SOcket CAT) establishes two bidirectional byte streams and
        transfers data between them.
-       Data channels may be files, pipes, devices (terminal or modem, etc.), or 
-       sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking, 
-       logging and tracing, different modes for interprocess communication and 
+       Data channels may be files, pipes, devices (terminal or modem, etc.), or
+       sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,
+       logging and tracing, different modes for interprocess communication and
        many more options.
 endef
 
index a41a929..a8eee61 100644 (file)
@@ -1,7 +1,6 @@
-diff -ruN socat-1.4-old/Makefile.in socat-1.4-new/Makefile.in
---- socat-1.4-old/Makefile.in  2005-09-10 22:09:11.000000000 +0200
-+++ socat-1.4-new/Makefile.in  2005-10-08 17:12:45.000000000 +0200
-@@ -36,7 +36,8 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -37,7 +37,8 @@
  
  #0 CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
  CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(CPPFLAGS)
index 372383a..ea6be13 100644 (file)
@@ -1,6 +1,5 @@
-diff -ruN socat-1.4-old/sslcls.c socat-1.4-new/sslcls.c
---- socat-1.4-old/sslcls.c     2005-03-12 19:06:54.000000000 +0100
-+++ socat-1.4-new/sslcls.c     2006-12-18 12:26:32.000000000 +0100
+--- a/sslcls.c
++++ b/sslcls.c
 @@ -35,6 +35,7 @@
     return result;
  }
@@ -17,10 +16,9 @@ diff -ruN socat-1.4-old/sslcls.c socat-1.4-new/sslcls.c
  
  SSL_METHOD *sycSSLv3_client_method(void) {
     SSL_METHOD *result;
-diff -ruN socat-1.4-old/xio-openssl.c socat-1.4-new/xio-openssl.c
---- socat-1.4-old/xio-openssl.c        2005-09-04 11:40:45.000000000 +0200
-+++ socat-1.4-new/xio-openssl.c        2006-12-18 12:27:17.000000000 +0100
-@@ -612,9 +612,12 @@
+--- a/xio-openssl.c
++++ b/xio-openssl.c
+@@ -676,9 +676,12 @@
  
     if (!server) {
        if (me_str != 0) {
@@ -34,7 +32,7 @@ diff -ruN socat-1.4-old/xio-openssl.c socat-1.4-new/xio-openssl.c
            method = sycSSLv3_client_method();
         } else if (!strcasecmp(me_str, "SSLv23") || !strcasecmp(me_str, "SSL23") ||
                    !strcasecmp(me_str, "SSL")) {
-@@ -631,9 +634,12 @@
+@@ -695,9 +698,12 @@
        }
     } else /* server */ {
        if (me_str != 0) {