[package] update libcurl to 7.19.4
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 3 Apr 2009 09:10:42 +0000 (09:10 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 3 Apr 2009 09:10:42 +0000 (09:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15085 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/curl/Makefile
libs/curl/patches/100-cross_compile.patch
libs/curl/patches/510-no_sslv2.patch

index 7716edc..840b756 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.17.1
+PKG_VERSION:=7.19.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -20,7 +20,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=1fa635d1dfde8337c98c82749d75c1de
+PKG_MD5SUM:=2734167c1e5f7ce6be99b75d2d371d85
 
 PKG_FIXUP = libtool
 
index 0f61f05..cfe2acf 100644 (file)
@@ -35,25 +35,25 @@ Index: curl-7.17.1/configure
  fi
  
  
-@@ -27741,18 +27722,6 @@
+@@ -25704,18 +25685,6 @@
  fi
  
--
 -      if test "x$USE_GNUTLS" = "xyes"; then
 -        { echo "$as_me:$LINENO: detected GnuTLS version $version" >&5
 -echo "$as_me: detected GnuTLS version $version" >&6;}
 -
+-        if test -n "$gtlslib"; then
 -
--        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
--        export LD_LIBRARY_PATH
--        { echo "$as_me:$LINENO: Added $gtlsprefix/lib$libsuff to LD_LIBRARY_PATH" >&5
--echo "$as_me: Added $gtlsprefix/lib$libsuff to LD_LIBRARY_PATH" >&6;}
+-          LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+-          export LD_LIBRARY_PATH
+-          { echo "$as_me:$LINENO: Added $gtlslib to LD_LIBRARY_PATH" >&5
+-echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
+-        fi
 -      fi
--
      fi
  
-   fi
 @@ -27951,17 +27920,6 @@
  fi
  
@@ -114,26 +114,27 @@ Index: curl-7.17.1/configure.ac
  fi
  
  dnl **********************************************************************
-@@ -1464,19 +1440,6 @@
+@@ -1610,20 +1586,6 @@
           CPPFLAGS="$CLEANCPPFLAGS"
         ])
  
 -      if test "x$USE_GNUTLS" = "xyes"; then
 -        AC_MSG_NOTICE([detected GnuTLS version $version])
 -
--        dnl when shared libs were found in a path that the run-time
--        dnl linker doesn't search through, we need to add it to
--        dnl LD_LIBRARY_PATH to prevent further configure tests to fail
--        dnl due to this
+-        if test -n "$gtlslib"; then
+-          dnl when shared libs were found in a path that the run-time
+-          dnl linker doesn't search through, we need to add it to
+-          dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+-          dnl due to this
 -
--        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
--        export LD_LIBRARY_PATH
--        AC_MSG_NOTICE([Added $gtlsprefix/lib$libsuff to LD_LIBRARY_PATH])
+-          LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+-          export LD_LIBRARY_PATH
+-          AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
+-        fi
 -      fi
--
      fi
  
-   fi dnl GNUTLS not disabled
 @@ -1544,19 +1507,6 @@
           CPPFLAGS="$CLEANCPPFLAGS"
         ])
index d6d4dbf..19fee70 100644 (file)
@@ -16,16 +16,16 @@ diff -ruN curl-7.14.0-old/lib/ssluse.c curl-7.14.0-new/lib/ssluse.c
 diff -ruN curl-7.14.0-old/src/main.c curl-7.14.0-new/src/main.c
 --- curl-7.14.0-old/src/main.c 2005-05-12 09:28:03.000000000 +0200
 +++ curl-7.14.0-new/src/main.c 2006-12-18 10:47:48.000000000 +0100
-@@ -425,7 +425,9 @@
-     " -z/--time-cond <time> Transfer based on a time condition",
-     " -0/--http1.0       Use HTTP 1.0 (H)",
-     " -1/--tlsv1         Use TLSv1 (SSL)",
+@@ -819,7 +819,9 @@
+ #endif
+     " -Y/--speed-limit   Stop transfer if below speed-limit for 'speed-time' secs",
+     " -y/--speed-time    Time needed to trig speed-limit abort. Defaults to 30",
 +#ifndef OPENSSL_NO_SSL2
      " -2/--sslv2         Use SSLv2 (SSL)",
 +#endif
      " -3/--sslv3         Use SSLv3 (SSL)",
-     "    --3p-quote      like -Q for the source URL for 3rd party transfer (F)",
-     "    --3p-url        source URL to activate 3rd party transfer (F)",
+     "    --stderr <file> Where to redirect stderr. - means stdout",
+     "    --tcp-nodelay   Use the TCP_NODELAY option",
 @@ -1671,10 +1673,12 @@
        /* TLS version 1 */
        config->ssl_version = CURL_SSLVERSION_TLSv1;