fix php4 compile on arm, add fpic while we're at it
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Aug 2008 11:50:14 +0000 (11:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Aug 2008 11:50:14 +0000 (11:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12265 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php4/Makefile
lang/php4/patches/100-compile_fix.patch [new file with mode: 0644]

index a2a99c8..5c8bab0 100644 (file)
@@ -250,6 +250,8 @@ endif
 define Build/Configure
 endef
 
+TARGET_CFLAGS += $(if $(CONFIG_BIG_ENDIAN),-DIEEE_BIG_ENDIAN,-DIEEE_LITTLE_ENDIAN) $(FPIC)
+
 ifneq ($(CONFIG_PACKAGE_php4-cli),)
   define Build/Compile/php4-cli
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
diff --git a/lang/php4/patches/100-compile_fix.patch b/lang/php4/patches/100-compile_fix.patch
new file mode 100644 (file)
index 0000000..b62e21f
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Zend/zend_strtod.c
++++ b/Zend/zend_strtod.c
+@@ -117,6 +117,7 @@
+ # endif
+ #endif
++#if !defined(IEEE_BIG_ENDIAN) && !defined(IEEE_LITTLE_ENDIAN)
+ #ifdef WORDS_BIGENDIAN
+ #define IEEE_BIG_ENDIAN
+ #else
+@@ -141,6 +142,7 @@
+ #define uint32_t unsigned __int32
+ #define IEEE_LITTLE_ENDIAN
+ #endif
++#endif /* !defined(IEEE_BIG_ENDIAN) && !defined(IEEE_LITTLE_ENDIAN) */
+ #define Long  int32_t
+ #define ULong uint32_t