[package] update joe to 3.7 (#5469)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jul 2009 12:17:59 +0000 (12:17 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jul 2009 12:17:59 +0000 (12:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16801 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/joe/Makefile
utils/joe/patches/001-mathaway.patch

index 36920f6..c1a89d2 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=joe
-PKG_VERSION:=3.5
+PKG_VERSION:=3.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/joe-editor
-PKG_MD5SUM:=9bdffecce7ef910feaa06452d48843de
+PKG_MD5SUM:=66de1b073e869ba12abbfcde3885c577
 
 include $(INCLUDE_DIR)/package.mk
 
index 6cb3d20..99fc930 100644 (file)
@@ -1,8 +1,6 @@
-Index: joe-3.5/umath.c
-===================================================================
---- joe-3.5.orig/umath.c       2007-08-23 13:56:53.000000000 +0200
-+++ joe-3.5/umath.c    2007-08-23 13:56:53.000000000 +0200
-@@ -378,7 +378,6 @@
+--- a/umath.c
++++ b/umath.c
+@@ -378,7 +378,6 @@ double m_cos(double n) { return cos(n); 
  double m_tan(double n) { return tan(n); }
  double m_exp(double n) { return exp(n); }
  double m_sqrt(double n) { return sqrt(n); }
@@ -10,7 +8,7 @@ Index: joe-3.5/umath.c
  double m_log(double n) { return log(n); }
  double m_log10(double n) { return log10(n); }
  double m_asin(double n) { return asin(n); }
-@@ -387,19 +386,10 @@
+@@ -387,19 +386,10 @@ double m_atan(double n) { return atan(n)
  double m_sinh(double n) { return sinh(n); }
  double m_cosh(double n) { return cosh(n); }
  double m_tanh(double n) { return tanh(n); }
@@ -30,7 +28,7 @@ Index: joe-3.5/umath.c
  
  double calc(BW *bw, unsigned char *s)
  {
-@@ -414,7 +404,6 @@
+@@ -414,7 +404,6 @@ double calc(BW *bw, unsigned char *s)
                v = get(USTR "tan"); v->func = m_tan;
                v = get(USTR "exp"); v->func = m_exp;
                v = get(USTR "sqrt"); v->func = m_sqrt;
@@ -38,7 +36,7 @@ Index: joe-3.5/umath.c
                v = get(USTR "ln"); v->func = m_log;
                v = get(USTR "log"); v->func = m_log10;
                v = get(USTR "asin"); v->func = m_asin;
-@@ -425,19 +414,10 @@
+@@ -425,19 +414,10 @@ double calc(BW *bw, unsigned char *s)
                v = get(USTR "sinh"); v->func = m_sinh;
                v = get(USTR "cosh"); v->func = m_cosh;
                v = get(USTR "tanh"); v->func = m_tanh;