[package] add cgilib libtool fix from #5538
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Jul 2009 08:28:42 +0000 (08:28 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Jul 2009 08:28:42 +0000 (08:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16890 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/cgilib/Makefile

index 93c175c..88e091f 100644 (file)
@@ -14,9 +14,13 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.infodrom.org/projects/cgilib/download
 PKG_MD5SUM:=2c7053f58dfb06f7a80a112797ed7e86
+PKG_FIXUP = libtool
+
+LIBTOOL="$(STAGING_DIR)/host/bin/libtool"
 
 include $(INCLUDE_DIR)/package.mk
 
+
 define Package/cgilib
   SECTION:=libs
   CATEGORY:=Libraries
@@ -31,6 +35,7 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                 OFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               LIBTOOL="$(LIBTOOL)" \
                 install
 endef