ortp: fix memset size argument usage
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Mar 2014 16:52:16 +0000 (16:52 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Mar 2014 16:52:16 +0000 (16:52 +0000)
As reported by GCC 4.8, the size argument passed to memset() was incorrect.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39923 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/ortp/Makefile
libs/ortp/patches/001-memset_fix.patch [new file with mode: 0644]

index 6ba9031..801bba0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ortp
 PKG_VERSION:=0.16.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
diff --git a/libs/ortp/patches/001-memset_fix.patch b/libs/ortp/patches/001-memset_fix.patch
new file mode 100644 (file)
index 0000000..89e2359
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/stun.c
++++ b/src/stun.c
+@@ -399,7 +399,7 @@ stunParseMessage( char* buf, unsigned in
+    char* body;
+    unsigned int size;
+        ortp_debug("stun: Received stun message: %i bytes\n", bufLen);
+-   memset(msg, 0, sizeof(msg));
++   memset(msg, 0, sizeof(*msg));
+       
+    if (sizeof(StunMsgHdr) > bufLen)
+    {