this patch updates gettext to 0.17.
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 04:39:41 +0000 (04:39 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 04:39:41 +0000 (04:39 +0000)
-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19767 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gettext/Makefile
libs/gettext/patches/001-no_examples_and_tests.patch
libs/gettext/patches/100-error_progname.patch
libs/gettext/patches/110-no_relink_install.patch
libs/gettext/patches/120-uclibc-nolocale.patch
libs/gettext/patches/130-wchar_fix.patch [new file with mode: 0644]
libs/gettext/patches/140-libtool_specify_tag.patch [new file with mode: 0644]
libs/gettext/patches/150-disable_libxml_iconv.patch [new file with mode: 0644]

index ce3656e..f7c4daa 100644 (file)
@@ -8,19 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext
-PKG_VERSION:=0.16.1
-PKG_RELEASE:=5
+PKG_VERSION:=0.17
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=3d9ad24301c6d6b17ec30704a13fe127
+PKG_MD5SUM:=58a2bc6d39c0ba57823034d55d65d606
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-
 define Package/libintl
   SECTION:=libs
   CATEGORY:=Libraries
@@ -46,13 +45,12 @@ CONFIGURE_ARGS += \
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl/include
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/lib/libintl/include/
+
        $(INSTALL_DIR) $(1)/usr/lib/libintl/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.{a,so*} $(1)/usr/lib/libintl/lib/
 
        $(INSTALL_DIR) $(1)/usr/share/aclocal
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
-               $(1)/usr/share/aclocal/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
 endef
 
 define Package/libintl/install
index db53b89..6126846 100644 (file)
@@ -1,7 +1,7 @@
-diff -ruN gettext-0.16.1-old/autoconf-lib-link/Makefile.in gettext-0.16.1-new/autoconf-lib-link/Makefile.in
---- gettext-0.16.1-old/autoconf-lib-link/Makefile.in   2006-11-27 18:33:54.000000000 +0100
-+++ gettext-0.16.1-new/autoconf-lib-link/Makefile.in   2007-08-22 21:18:41.000000000 +0200
-@@ -204,7 +204,7 @@
+diff -pruN gettext-0.17.orig/autoconf-lib-link/Makefile.in gettext-0.17/autoconf-lib-link/Makefile.in
+--- gettext-0.17.orig/autoconf-lib-link/Makefile.in    2009-05-19 17:11:00.057467286 +0200
++++ gettext-0.17/autoconf-lib-link/Makefile.in 2009-05-19 17:12:04.539791314 +0200
+@@ -206,7 +206,7 @@ EXTRA_DIST = config.rpath
  DISTCLEANFILES = build-aux/config.guess build-aux/config.sub \
        build-aux/install-sh build-aux/ltmain.sh build-aux/missing \
        build-aux/config.rpath
@@ -10,10 +10,10 @@ diff -ruN gettext-0.16.1-old/autoconf-lib-link/Makefile.in gettext-0.16.1-new/au
  
  # Subdirectories with separate autoconfiguration.
  CONFIGURES_RPATHX = $(srcdir)/tests/rpathx/Makefile.in $(srcdir)/tests/rpathx/aclocal.m4 $(srcdir)/tests/rpathx/configure
-diff -ruN gettext-0.16.1-old/gettext-runtime/Makefile.in gettext-0.16.1-new/gettext-runtime/Makefile.in
---- gettext-0.16.1-old/gettext-runtime/Makefile.in     2006-11-27 18:34:14.000000000 +0100
-+++ gettext-0.16.1-new/gettext-runtime/Makefile.in     2007-08-22 21:18:12.000000000 +0200
-@@ -140,7 +140,7 @@
+diff -pruN gettext-0.17.orig/gettext-runtime/Makefile.in gettext-0.17/gettext-runtime/Makefile.in
+--- gettext-0.17.orig/gettext-runtime/Makefile.in      2009-05-19 17:10:59.798239310 +0200
++++ gettext-0.17/gettext-runtime/Makefile.in   2009-05-19 17:12:40.225999245 +0200
+@@ -154,7 +154,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
  ETAGS = etags
  CTAGS = ctags
  DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
@@ -22,15 +22,15 @@ diff -ruN gettext-0.16.1-old/gettext-runtime/Makefile.in gettext-0.16.1-new/gett
  DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
  distdir = $(PACKAGE)-$(VERSION)
  top_distdir = $(distdir)
-diff -ruN gettext-0.16.1-old/gettext-tools/Makefile.in gettext-0.16.1-new/gettext-tools/Makefile.in
---- gettext-0.16.1-old/gettext-tools/Makefile.in       2006-11-27 18:34:56.000000000 +0100
-+++ gettext-0.16.1-new/gettext-tools/Makefile.in       2007-08-22 21:19:11.000000000 +0200
-@@ -484,7 +484,7 @@
+diff -pruN gettext-0.17.orig/gettext-tools/Makefile.in gettext-0.17/gettext-tools/Makefile.in
+--- gettext-0.17.orig/gettext-tools/Makefile.in        2009-05-19 17:11:00.269723630 +0200
++++ gettext-0.17/gettext-tools/Makefile.in     2009-05-19 17:14:09.041478317 +0200
+@@ -724,7 +724,7 @@ top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
  ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../m4 -I gnulib-m4 -I libgettextpo/gnulib-m4
--SUBDIRS = doc intl gnulib-lib libgrep libuniname src libgettextpo po projects misc man m4 tests examples
-+SUBDIRS = doc intl gnulib-lib libgrep libuniname src libgettextpo po projects misc man m4
+-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
++SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
  
  # Allow users to use "gnulib-tool --update".
  
index 42a5790..2db2849 100644 (file)
@@ -1,8 +1,7 @@
-Index: gettext-0.16.1/gettext-runtime/intl/intl-compat.c
-===================================================================
---- gettext-0.16.1.orig/gettext-runtime/intl/intl-compat.c     2007-12-29 22:51:09.363903016 +0100
-+++ gettext-0.16.1/gettext-runtime/intl/intl-compat.c  2007-12-29 22:51:14.048169957 +0100
-@@ -131,3 +131,7 @@
+diff -pruN gettext-0.17.orig/gettext-runtime/intl/intl-compat.c gettext-0.17/gettext-runtime/intl/intl-compat.c
+--- gettext-0.17.orig/gettext-runtime/intl/intl-compat.c       2009-05-19 17:15:41.881718113 +0200
++++ gettext-0.17/gettext-runtime/intl/intl-compat.c    2009-05-19 17:16:33.585732221 +0200
+@@ -131,3 +131,7 @@ bind_textdomain_codeset (const char *dom
  {
    return libintl_bind_textdomain_codeset (domainname, codeset);
  }
index fd1a602..87e01b4 100644 (file)
@@ -1,7 +1,7 @@
-diff -urN gettext-0.16.1/gettext-tools/gnulib-lib/Makefile.in gettext-0.16.1.new/gettext-tools/gnulib-lib/Makefile.in
---- gettext-0.16.1/gettext-tools/gnulib-lib/Makefile.in        2006-11-27 18:34:53.000000000 +0100
-+++ gettext-0.16.1.new/gettext-tools/gnulib-lib/Makefile.in    2008-09-21 18:18:52.000000000 +0200
-@@ -648,7 +648,6 @@
+diff -pruN gettext-0.17.orig/gettext-tools/gnulib-lib/Makefile.in gettext-0.17/gettext-tools/gnulib-lib/Makefile.in
+--- gettext-0.17.orig/gettext-tools/gnulib-lib/Makefile.in     2009-05-19 17:17:24.413508248 +0200
++++ gettext-0.17/gettext-tools/gnulib-lib/Makefile.in  2009-05-19 17:19:06.457520598 +0200
+@@ -1330,7 +1330,6 @@ install-libLTLIBRARIES: $(lib_LTLIBRARIE
          if test -f $$p; then \
            f=$(am__strip_dir) \
            echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
@@ -9,10 +9,10 @@ diff -urN gettext-0.16.1/gettext-tools/gnulib-lib/Makefile.in gettext-0.16.1.new
          else :; fi; \
        done
  
-diff -urN gettext-0.16.1/gettext-tools/libgettextpo/Makefile.in gettext-0.16.1.new/gettext-tools/libgettextpo/Makefile.in
---- gettext-0.16.1/gettext-tools/libgettextpo/Makefile.in      2006-11-27 18:48:21.000000000 +0100
-+++ gettext-0.16.1.new/gettext-tools/libgettextpo/Makefile.in  2008-09-21 18:19:27.000000000 +0200
-@@ -660,7 +660,6 @@
+diff -pruN gettext-0.17.orig/gettext-tools/libgettextpo/Makefile.in gettext-0.17/gettext-tools/libgettextpo/Makefile.in
+--- gettext-0.17.orig/gettext-tools/libgettextpo/Makefile.in   2009-05-19 17:17:24.125764150 +0200
++++ gettext-0.17/gettext-tools/libgettextpo/Makefile.in        2009-05-19 17:23:11.101467088 +0200
+@@ -953,7 +953,6 @@ install-libLTLIBRARIES: $(lib_LTLIBRARIE
          if test -f $$p; then \
            f=$(am__strip_dir) \
            echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
@@ -20,10 +20,10 @@ diff -urN gettext-0.16.1/gettext-tools/libgettextpo/Makefile.in gettext-0.16.1.n
          else :; fi; \
        done
  
-diff -urN gettext-0.16.1/gettext-tools/src/Makefile.in gettext-0.16.1.new/gettext-tools/src/Makefile.in
---- gettext-0.16.1/gettext-tools/src/Makefile.in       2006-11-27 18:34:56.000000000 +0100
-+++ gettext-0.16.1.new/gettext-tools/src/Makefile.in   2008-09-21 18:19:10.000000000 +0200
-@@ -1097,7 +1097,6 @@
+diff -pruN gettext-0.17.orig/gettext-tools/src/Makefile.in gettext-0.17/gettext-tools/src/Makefile.in
+--- gettext-0.17.orig/gettext-tools/src/Makefile.in    2009-05-19 17:17:24.718249813 +0200
++++ gettext-0.17/gettext-tools/src/Makefile.in 2009-05-19 17:24:34.473723917 +0200
+@@ -1337,7 +1337,6 @@ install-libLTLIBRARIES: $(lib_LTLIBRARIE
          if test -f $$p; then \
            f=$(am__strip_dir) \
            echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
@@ -31,7 +31,7 @@ diff -urN gettext-0.16.1/gettext-tools/src/Makefile.in gettext-0.16.1.new/gettex
          else :; fi; \
        done
  
-@@ -1129,7 +1128,6 @@
+@@ -1369,7 +1368,6 @@ install-binPROGRAMS: $(bin_PROGRAMS)
          ; then \
            f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
           echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
index 2259dcd..a1cb44c 100644 (file)
@@ -1,8 +1,7 @@
-Index: gettext-0.16.1/gettext-runtime/intl/localename.c
-===================================================================
---- gettext-0.16.1.orig/gettext-runtime/intl/localename.c      2007-12-29 22:51:09.363903016 +0100
-+++ gettext-0.16.1/gettext-runtime/intl/localename.c   2008-10-26 16:57:14.048169957 +0100
-@@ -988,7 +988,7 @@
+diff -pruN gettext-0.17.orig/gettext-runtime/intl/localename.c gettext-0.17/gettext-runtime/intl/localename.c
+--- gettext-0.17.orig/gettext-runtime/intl/localename.c        2009-05-19 17:25:21.925748747 +0200
++++ gettext-0.17/gettext-runtime/intl/localename.c     2009-05-19 17:26:12.773472555 +0200
+@@ -996,7 +996,7 @@ gl_locale_name_posix (int category, cons
  {
    /* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
       On some systems this can be done by the 'setlocale' function itself.  */
diff --git a/libs/gettext/patches/130-wchar_fix.patch b/libs/gettext/patches/130-wchar_fix.patch
new file mode 100644 (file)
index 0000000..6fbac64
--- /dev/null
@@ -0,0 +1,103 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+# 
+# T2 SDE: package/.../gettext/wchar-fix.patch
+# Copyright (C) 2008 The T2 SDE Project
+# 
+# More information can be found in the files COPYING and README.
+# 
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+# 
+# T2 SDE: package/.../gettext/wchar-fix.patch
+# Copyright (C) 2008 The T2 SDE Project
+# 
+# More information can be found in the files COPYING and README.
+# 
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+#
+# Taken from: http://svn.exactcode.de/t2/trunk/package/base/gettext/wchar-fix.patch
+#
+
+diff -pruN gettext-0.17.orig//gettext-runtime/gnulib-lib/wchar.in.h gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h
+--- gettext-0.17.orig//gettext-runtime/gnulib-lib/wchar.in.h   2010-02-17 15:36:18.822918689 +0100
++++ gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h 2010-02-17 15:38:37.686548691 +0100
+@@ -26,6 +26,14 @@
+  * the declaration of wcwidth().
+  */
++#ifdef __need_mbstate_t
++/* Special invocation convention inside glibc header files.  */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention.  */
++
+ #ifndef _GL_WCHAR_H
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@ extern int wcwidth (int /* actually wcha
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
+diff -pruN gettext-0.17.orig//gettext-tools/gnulib-lib/wchar.in.h gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h
+--- gettext-0.17.orig//gettext-tools/gnulib-lib/wchar.in.h     2010-02-17 15:36:21.302471149 +0100
++++ gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h   2010-02-17 15:40:10.667180066 +0100
+@@ -26,6 +26,14 @@
+  * the declaration of wcwidth().
+  */
++#ifdef __need_mbstate_t
++/* Special invocation convention inside glibc header files.  */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention.  */
++
+ #ifndef _GL_WCHAR_H
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@ extern int wcwidth (int /* actually wcha
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
+diff -pruN gettext-0.17.orig//gettext-tools/libgettextpo/wchar.in.h gettext-0.17/gettext-tools/libgettextpo/wchar.in.h
+--- gettext-0.17.orig//gettext-tools/libgettextpo/wchar.in.h   2010-02-17 15:36:19.870408142 +0100
++++ gettext-0.17/gettext-tools/libgettextpo/wchar.in.h 2010-02-17 15:40:48.206658667 +0100
+@@ -26,6 +26,14 @@
+  * the declaration of wcwidth().
+  */
++#ifdef __need_mbstate_t
++/* Special invocation convention inside glibc header files.  */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention.  */
++
+ #ifndef _GL_WCHAR_H
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@ extern int wcwidth (int /* actually wcha
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
diff --git a/libs/gettext/patches/140-libtool_specify_tag.patch b/libs/gettext/patches/140-libtool_specify_tag.patch
new file mode 100644 (file)
index 0000000..b49fce1
--- /dev/null
@@ -0,0 +1,99 @@
+diff -pruN gettext-0.17.orig//gettext-runtime/intl/Makefile.in gettext-0.17/gettext-runtime/intl/Makefile.in
+--- gettext-0.17.orig//gettext-runtime/intl/Makefile.in        2010-02-17 16:33:29.922429524 +0100
++++ gettext-0.17/gettext-runtime/intl/Makefile.in      2010-02-17 16:40:47.294419311 +0100
+@@ -191,7 +191,7 @@ libintl.a libgnuintl.a: $(OBJECTS)
+       $(RANLIB) $@
+ libintl.la libgnuintl.la: $(OBJECTS) $(OBJECTS_RES_@WOE32@)
+-      $(LIBTOOL) --mode=link \
++      $(LIBTOOL) --tag=CC --mode=link \
+         $(CC) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) $(LDFLAGS) -o $@ \
+         $(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) @LTLIBTHREAD@ @LTLIBC@ \
+         $(OBJECTS_RES_@WOE32@) \
+@@ -219,59 +219,59 @@ LTV_AGE=0
+       rm -f $*.h
+ bindtextdom.lo: $(srcdir)/bindtextdom.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/bindtextdom.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/bindtextdom.c
+ dcgettext.lo: $(srcdir)/dcgettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcgettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dcgettext.c
+ dgettext.lo: $(srcdir)/dgettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dgettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dgettext.c
+ gettext.lo: $(srcdir)/gettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/gettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/gettext.c
+ finddomain.lo: $(srcdir)/finddomain.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/finddomain.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/finddomain.c
+ hash-string.lo: $(srcdir)/hash-string.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/hash-string.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/hash-string.c
+ loadmsgcat.lo: $(srcdir)/loadmsgcat.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/loadmsgcat.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/loadmsgcat.c
+ localealias.lo: $(srcdir)/localealias.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localealias.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/localealias.c
+ textdomain.lo: $(srcdir)/textdomain.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/textdomain.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/textdomain.c
+ l10nflist.lo: $(srcdir)/l10nflist.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/l10nflist.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/l10nflist.c
+ explodename.lo: $(srcdir)/explodename.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/explodename.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/explodename.c
+ dcigettext.lo: $(srcdir)/dcigettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcigettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dcigettext.c
+ dcngettext.lo: $(srcdir)/dcngettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcngettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dcngettext.c
+ dngettext.lo: $(srcdir)/dngettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dngettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dngettext.c
+ ngettext.lo: $(srcdir)/ngettext.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/ngettext.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/ngettext.c
+ plural.lo: $(srcdir)/plural.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/plural.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/plural.c
+ plural-exp.lo: $(srcdir)/plural-exp.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/plural-exp.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/plural-exp.c
+ localcharset.lo: $(srcdir)/localcharset.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localcharset.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/localcharset.c
+ lock.lo: $(srcdir)/lock.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/lock.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/lock.c
+ relocatable.lo: $(srcdir)/relocatable.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/relocatable.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/relocatable.c
+ langprefs.lo: $(srcdir)/langprefs.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/langprefs.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/langprefs.c
+ localename.lo: $(srcdir)/localename.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localename.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/localename.c
+ log.lo: $(srcdir)/log.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/log.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/log.c
+ printf.lo: $(srcdir)/printf.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/printf.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/printf.c
+ version.lo: $(srcdir)/version.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/version.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/version.c
+ osdep.lo: $(srcdir)/osdep.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/osdep.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/osdep.c
+ intl-compat.lo: $(srcdir)/intl-compat.c
+-      $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/intl-compat.c
++      $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/intl-compat.c
+ # This rule is executed only on Woe32 systems.
+ # The following sed expressions come from the windres-options script. They are
diff --git a/libs/gettext/patches/150-disable_libxml_iconv.patch b/libs/gettext/patches/150-disable_libxml_iconv.patch
new file mode 100644 (file)
index 0000000..c12c35a
--- /dev/null
@@ -0,0 +1,24 @@
+diff -pruN gettext-0.17.orig//gettext-tools/gnulib-lib/libxml/xmlversion.in.h gettext-0.17/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
+--- gettext-0.17.orig//gettext-tools/gnulib-lib/libxml/xmlversion.in.h 2010-02-17 17:35:35.758950208 +0100
++++ gettext-0.17/gettext-tools/gnulib-lib/libxml/xmlversion.in.h       2010-02-17 17:56:56.510418934 +0100
+@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
+  *
+  * Whether iconv support is available
+  */
+-#if 1
++#if 0
+ #define LIBXML_ICONV_ENABLED
+ #endif
+diff -pruN gettext-0.17.orig//gnulib-local/lib/libxml/xmlversion.in.h gettext-0.17/gnulib-local/lib/libxml/xmlversion.in.h
+--- gettext-0.17.orig//gnulib-local/lib/libxml/xmlversion.in.h 2010-02-17 17:35:34.787184901 +0100
++++ gettext-0.17/gnulib-local/lib/libxml/xmlversion.in.h       2010-02-17 17:56:49.578484210 +0100
+@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
+  *
+  * Whether iconv support is available
+  */
+-#if 1
++#if 0
+ #define LIBXML_ICONV_ENABLED
+ #endif