[package] collectd needs -fPIC to be passed to CFLAGS to build properly on x86_64...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Jan 2009 15:20:49 +0000 (15:20 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Jan 2009 15:20:49 +0000 (15:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14092 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile

index 8ae8d1d..44bb7f1 100644 (file)
@@ -281,7 +281,7 @@ PKG_CONFIGURE_OPTS:= \
        --with-fp-layout=nothing
 
 CONFIGURE_VARS+= \
-       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS $(FPIC)" \
        KERNEL_DIR="$(LINUX_DIR)"
 
 # list of permanently disabled plugins