add c++ bindings for cairo
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Nov 2009 02:10:49 +0000 (02:10 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Nov 2009 02:10:49 +0000 (02:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18394 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/lib/cairomm/Makefile [new file with mode: 0644]

diff --git a/Xorg/lib/cairomm/Makefile b/Xorg/lib/cairomm/Makefile
new file mode 100644 (file)
index 0000000..d30b609
--- /dev/null
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2008-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cairomm
+PKG_VERSION:=1.8.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://cairographics.org/releases/
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+
+define Package/cairomm
+  SECTION:=xorg-libs
+  CATEGORY:=Xorg
+  SUBMENU:=libraries
+  TITLE:=Multi-platform 2D graphics library
+  DEPENDS:=+libsigcxx +cairo
+endef
+
+define Package/cairomm/description
+c++-bindings for cairo
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) \
+               $(1)/usr/lib \
+               $(1)/usr/lib/pkgconfig \
+               $(1)/usr/include
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/* \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/* \
+               $(1)/usr/include/
+endef
+
+define Package/cairomm/install
+       $(INSTALL_DIR) \
+               $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,cairomm))