replace sdcc prereq check with a simple command test
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Jan 2007 01:13:44 +0000 (01:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Jan 2007 01:13:44 +0000 (01:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6152 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/firmwarehotplug/Makefile

index cff3be1..5011517 100644 (file)
@@ -49,17 +49,6 @@ endef
 
 $(eval $(call BuildPackage,firmwarehotplug))
 
-define Require/working-sdcc
-       echo 'int main() { return 0; }' >$(TMP_DIR)/a.c; \
-       sdcc -o $(TMP_DIR)/a.out $(TMP_DIR)/a.c && { \
-               rm -f $(TMP_DIR)/a.* \
-       } || { \
-               rm -f $(TMP_DIR)/a.*; \
-               false \
-       }
-
-endef
-
-$(eval $(call Require,working-sdcc, \
+$(eval $(call RequireCommand,sdcc, \
         Please install the SDCC Cross Compiler (sdcc). \
 ))