tracked down sstrip bug to strip being called from squashfs
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Aug 2004 06:36:24 +0000 (06:36 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Aug 2004 06:36:24 +0000 (06:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@143 3c298f89-4303-0410-b956-a3cf2f4a3e73

obsolete-buildroot/make/squashfsroot.mk

index 5f5233f..3e1b34a 100644 (file)
@@ -36,7 +36,7 @@ squashfs-dirclean:
 
 squashfsroot: squashfs
        #-@find $(TARGET_DIR)/lib -type f -name \*.so\* | xargs $(STRIP) --strip-unneeded 2>/dev/null || true;
-       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
        #$(SQUASHFS_DIR)/squashfs-tools/mksquashfs -q -D $(SOURCE_DIR)/device_table.txt $(TARGET_DIR) $(IMAGE)