Fix logrotate compilation
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 13:14:37 +0000 (13:14 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Sep 2007 13:14:37 +0000 (13:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8627 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/logrotate/Makefile

index 51f8380..e6b8195 100644 (file)
@@ -43,9 +43,12 @@ define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+
 define Build/Compile
        $(call Build/Compile/Default, \
-               RPM_OPT_FLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
+               RPM_OPT_FLAGS:="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
                logrotate \
        )