[packages] libdlna: fix build failure introduced by [21056], restore fix from [12678...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 28 Apr 2010 01:39:26 +0000 (01:39 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 28 Apr 2010 01:39:26 +0000 (01:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21215 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libdlna/Makefile

index a2b6989..a805dd7 100644 (file)
@@ -39,7 +39,7 @@ define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS) -lpthread -lz" \
+               LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib" \
                HOST_CC="$(HOSTCC)" \
                ./configure \
                --cross-compile \
@@ -53,6 +53,11 @@ define Build/Configure
        )
 endef
 
+# XXX: fix build on systems where install is not at its usual location
+# INSTALL defaults to /usr/bin/install
+MAKE_INSTALL_FLAGS += \
+       INSTALL="install" \
+
 TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev