update motion (patch from #1868)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2007 16:11:41 +0000 (16:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2007 16:11:41 +0000 (16:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7570 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/motion/Makefile
multimedia/motion/patches/001-ffmpeg.patch
multimedia/motion/patches/002-honor_cppflags.patch
multimedia/motion/patches/003-sn9c102-common-buffer.patch

index 9d2d10e..04ea26a 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=20070331-051001
+PKG_VERSION:=3.2.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
-               @SF/motion
-PKG_MD5SUM:=16e58186022dfee1c0dcaf03cf5393e5
+PKG_SOURCE_URL:=@SF/motion
+PKG_MD5SUM:=b4af6e10532fcdec89060bc61a27fc3a
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
index 50c5748..3489ef2 100644 (file)
@@ -1,7 +1,8 @@
-diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
---- motion-3.2.8.old/motion.c  2007-03-31 12:54:31.000000000 +0200
-+++ motion-3.2.8/motion.c      2007-03-31 13:08:27.000000000 +0200
-@@ -1282,6 +1282,7 @@
+Index: motion-3.2.7/motion.c
+===================================================================
+--- motion-3.2.7.orig/motion.c 2007-06-11 08:27:27.000000000 +0100
++++ motion-3.2.7/motion.c      2007-06-11 08:27:35.000000000 +0100
+@@ -1279,6 +1279,7 @@
                 * httpd-control snaps are always enabled.
                 */
  
@@ -9,7 +10,7 @@ diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
                /* time_current_frame is used both for snapshot and timelapse features */
                time_current_frame = cnt->currenttime;
  
-@@ -1291,7 +1292,7 @@
+@@ -1288,7 +1289,7 @@
                        event(cnt, EVENT_IMAGE_SNAPSHOT, newimg, NULL, NULL, cnt->currenttime_tm);
                        cnt->snapshot = 0;
                }
@@ -18,7 +19,7 @@ diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
  
        /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
  
-@@ -1366,9 +1367,9 @@
+@@ -1363,9 +1364,9 @@
                        event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
  
  
index 322fb77..0c0ba13 100644 (file)
@@ -1,6 +1,7 @@
-diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
---- motion-3.2.5.1-old/Makefile.in     2006-03-07 22:52:49.000000000 +0100
-+++ motion-3.2.5.1-new/Makefile.in     2006-03-27 22:04:34.000000000 +0200
+Index: motion-3.2.7/Makefile.in
+===================================================================
+--- motion-3.2.7.orig/Makefile.in      2007-06-11 08:26:33.000000000 +0100
++++ motion-3.2.7/Makefile.in   2007-06-11 08:27:55.000000000 +0100
 @@ -32,6 +32,7 @@
  ################################################################################
  CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
@@ -9,7 +10,7 @@ diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
  LDFLAGS      = @LDFLAGS@
  LIBS         = @LIBS@ 
  VIDEO_OBJ    = @VIDEO@
-@@ -115,7 +116,7 @@
+@@ -119,7 +120,7 @@
  ################################################################################
  $(DEPEND_FILE): *.h $(SRC)
        @echo "Generating dependencies, please wait..."
index 8a9693c..e43a1c0 100644 (file)
@@ -1,7 +1,7 @@
-Index: motion-3.2.8/motion.c
+Index: motion-3.2.7/motion.c
 ===================================================================
---- motion-3.2.8/motion.c      (revision 174)
-+++ motion-3.2.8/motion.c      (working copy)
+--- motion-3.2.7.orig/motion.c 2007-06-11 08:27:35.000000000 +0100
++++ motion-3.2.7/motion.c      2007-06-11 08:28:30.000000000 +0100
 @@ -474,8 +474,8 @@
        cnt->imgs.shotstamp = mymalloc(sizeof(int));