[package] add tmux (#6198)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Nov 2009 16:17:06 +0000 (16:17 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Nov 2009 16:17:06 +0000 (16:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18482 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/tmux/Makefile [new file with mode: 0644]

diff --git a/utils/tmux/Makefile b/utils/tmux/Makefile
new file mode 100644 (file)
index 0000000..160a8dc
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+
+PKG_NAME:=tmux
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/tmux
+PKG_MD5SUM:=faf2fc52ac3ae63d899f6fece2c112cd
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tmux
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Terminal multiplexer
+  DEPENDS:=+libncurses
+  URL:=http://tmux.sourceforge.net
+endef
+
+define Package/tmux/description
+  tmux is a modern, BSD-licensed alternative to GNU screen.
+endef
+
+define Build/Compile
+       CC="$(TARGET_CC)" \
+       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="$(TARGET_LDFLAGS)" \
+       TMUX_PLATFORM="Linux" \
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+endef
+
+define Package/tmux/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tmux $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,tmux))