clearsilver: fix building on non-linux systems
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Apr 2014 17:11:39 +0000 (17:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Apr 2014 17:11:39 +0000 (17:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40513 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/clearsilver/Makefile

index 40a567c..52d6ddc 100644 (file)
@@ -88,7 +88,8 @@ TARGET_CFLAGS+=$(FPIC)
 MAKE_FLAGS+= \
        $(TARGET_CONFIGURE_OPTS) \
        AR="$(AR) cr" \
-       LD="$(TARGET_CC) -o"
+       LD="$(TARGET_CC) -o" \
+       OSTYPE=Linux
 
 define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/