[package] fix stunnel restart, bump makefile (#5897, #6220)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jan 2010 12:14:16 +0000 (12:14 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jan 2010 12:14:16 +0000 (12:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18994 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/stunnel/Makefile
net/stunnel/files/stunnel.init

index ff16727..4693305 100644 (file)
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
 PKG_VERSION:=4.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=14dc3f8412947f0548975cbce74d6863
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index f74ff68..a3ea103 100644 (file)
@@ -26,5 +26,9 @@ start() {
 }
 
 stop() {
-       [ -f $PID_F ] && kill -9 $(cat $PID_F) && rm -f $PID_F
+       [ -f $PID_F ] && {
+               kill $(cat $PID_F)
+               kill -9 $(cat $PID_F)
+               rm -f $PID_F
+       }
 }