[packages] alsa-utils: include midi utilities in alsa-utils
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Jul 2012 20:19:08 +0000 (20:19 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Jul 2012 20:19:08 +0000 (20:19 +0000)
Along with http://patchwork.openwrt.org/patch/2144/ and
http://patchwork.openwrt.org/patch/2145/ this will enable the standard
ALSA midi utilities to be used in openwrt.

Signed-off-by: Adam Goode <adam@spicenitz.org>
Signed-off-by: Vasilis Tsiligiannis <b_tsiligiannis@silverton.gr>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32713 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/alsa-utils/Makefile

index 8c6823e..f203ecb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alsa-utils
 PKG_VERSION:=1.0.24.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
@@ -27,6 +27,14 @@ define Package/alsa-utils
   URL:=http://www.alsa-project.org/
 endef
 
+define Package/alsa-utils-seq
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+alsa-lib +libpthread
+  TITLE:=ALSA sequencer utilities
+  URL:=http://www.alsa-project.org/
+endef
+
 define Package/alsa-utils-tests
   $(call Package/alsa-utils/Default)
   SECTION:=utils
@@ -60,6 +68,16 @@ define Package/alsa-utils/install
            $(1)/usr/share/alsa/init/
 endef
 
+define Package/alsa-utils-seq/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aconnect $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amidi $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aplaymidi $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/arecordmidi $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aseqdump $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aseqnet $(1)/usr/bin/
+endef
+
 define Package/alsa-utils-tests/install
        $(INSTALL_DIR) $(1)/usr/{s,}bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/speaker-test $(1)/usr/bin/
@@ -70,4 +88,5 @@ define Package/alsa-utils-tests/install
 endef
 
 $(eval $(call BuildPackage,alsa-utils))
+$(eval $(call BuildPackage,alsa-utils-seq))
 $(eval $(call BuildPackage,alsa-utils-tests))