[packages] haproxy: bump to version 1.4.9 which obsoletes patch
authorheil <heil@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Nov 2010 11:45:09 +0000 (11:45 +0000)
committerheil <heil@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Nov 2010 11:45:09 +0000 (11:45 +0000)
                    001-clean..

git-svn-id: svn://svn.openwrt.org/openwrt/packages@23938 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/haproxy/Makefile
net/haproxy/patches/001-clean-listener-ressource-shortage.patch [deleted file]

index 44361cc..807ad7c 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
-PKG_VERSION:=1.4.8
-PKG_RELEASE:=4
+PKG_VERSION:=1.4.9
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.4/src
-PKG_MD5SUM:=104f4985b37bd9bac7a33e20fb6aaadf
+PKG_MD5SUM:=2cbcc95b54c0d803edaa13e7b4aeec25
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/net/haproxy/patches/001-clean-listener-ressource-shortage.patch b/net/haproxy/patches/001-clean-listener-ressource-shortage.patch
deleted file mode 100644 (file)
index 1299e5e..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/src/client.c
-+++ b/src/client.c
-@@ -1,7 +1,7 @@
- /*
-  * Client-side variables and functions.
-  *
-- * Copyright 2000-2009 Willy Tarreau <w@1wt.eu>
-+ * Copyright 2000-2010 Willy Tarreau <w@1wt.eu>
-  *
-  * This program is free software; you can redistribute it and/or
-  * modify it under the terms of the GNU General Public License
-@@ -33,6 +33,7 @@
- #include <proto/log.h>
- #include <proto/hdr_idx.h>
- #include <proto/pattern.h>
-+#include <proto/protocols.h>
- #include <proto/proto_tcp.h>
- #include <proto/proto_http.h>
- #include <proto/proxy.h>
-@@ -121,7 +122,7 @@ int event_accept(int fd) {
-               if ((s = pool_alloc2(pool2_session)) == NULL) { /* disable this proxy for a while */
-                       Alert("out of memory in event_accept().\n");
--                      EV_FD_CLR(fd, DIR_RD);
-+                      disable_listener(l);
-                       p->state = PR_STIDLE;
-                       goto out_close;
-               }
-@@ -149,7 +150,7 @@ int event_accept(int fd) {
-               if ((t = task_new()) == NULL) { /* disable this proxy for a while */
-                       Alert("out of memory in event_accept().\n");
--                      EV_FD_CLR(fd, DIR_RD);
-+                      disable_listener(l);
-                       p->state = PR_STIDLE;
-                       goto out_free_session;
-               }
-