Dbus needs the same trick as avahi to properly disable inotify/dnotify checks with 2.4
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 27 Sep 2008 14:39:08 +0000 (14:39 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 27 Sep 2008 14:39:08 +0000 (14:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12731 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/dbus/Makefile

index 24f0997..087415a 100644 (file)
@@ -69,7 +69,6 @@ CONFIGURE_ARGS += \
        --disable-ansi \
        --disable-asserts \
        --disable-console-owner-file \
-       --disable-dnotify \
        --disable-doxygen-docs \
        --disable-gcov \
        --disable-selinux \
@@ -85,6 +84,7 @@ CONFIGURE_ARGS += \
 
 CONFIGURE_VARS+= \
        ac_cv_have_abstract_sockets="yes" \
+       $(if $(CONFIG_LINUX_2_4),ac_cv_header_sys_inotify_h=no) \
 
 
 define Build/InstallDev