boost: avoid the python build dependency if python support is disabled
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Jul 2012 09:23:06 +0000 (09:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Jul 2012 09:23:06 +0000 (09:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32633 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/boost/Makefile

index d10a520..226558e 100644 (file)
@@ -116,7 +116,7 @@ endef
 define Package/boost-python
   $(call Package/boost/Default)
   TITLE+= (python)
-  DEPENDS+= +python
+  DEPENDS+= +PACKAGE_boost-python:python
 endef
 
 define Package/boost-random