Index: boa-0.94.13/src/list.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ boa-0.94.13/src/list.h 2008-06-15 23:21:11.000000000 +0200
++++ boa-0.94.13/src/list.h 2008-06-29 01:12:36.000000000 +0200
@@ -0,0 +1,601 @@
+#ifndef _LINUX_LIST_H
+#define _LINUX_LIST_H
Index: boa-0.94.13/src/plugin.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ boa-0.94.13/src/plugin.c 2008-06-29 00:39:43.000000000 +0200
++++ boa-0.94.13/src/plugin.c 2008-06-29 01:22:01.000000000 +0200
@@ -0,0 +1,190 @@
+/*
+ * Simple plugin API for boa
+
+ p = plugin_lookup(req);
+ if (!p)
-+ return 1;
++ return 0;
+
+ return plugin_run(req, p);
+}
+
Index: boa-0.94.13/src/request.c
===================================================================
---- boa-0.94.13.orig/src/request.c 2002-07-24 05:03:59.000000000 +0200
-+++ boa-0.94.13/src/request.c 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/request.c 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/request.c 2008-06-29 01:12:36.000000000 +0200
@@ -50,6 +50,7 @@
dequeue(&request_free, request_free); /* dequeue the head */
} else {
return init_cgi(req);
Index: boa-0.94.13/src/Makefile.in
===================================================================
---- boa-0.94.13.orig/src/Makefile.in 2002-03-24 23:20:19.000000000 +0100
-+++ boa-0.94.13/src/Makefile.in 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/Makefile.in 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/Makefile.in 2008-06-29 01:12:36.000000000 +0200
@@ -20,7 +20,7 @@
srcdir = @srcdir@
VPATH = @srcdir@:@srcdir@/../extras
Index: boa-0.94.13/src/boa.h
===================================================================
---- boa-0.94.13.orig/src/boa.h 2002-07-26 05:03:44.000000000 +0200
-+++ boa-0.94.13/src/boa.h 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/boa.h 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/boa.h 2008-06-29 01:12:36.000000000 +0200
@@ -37,6 +37,7 @@
#include <fcntl.h>
#include <limits.h> /* OPEN_MAX */
#endif
Index: boa-0.94.13/src/config.c
===================================================================
---- boa-0.94.13.orig/src/config.c 2002-07-26 05:04:29.000000000 +0200
-+++ boa-0.94.13/src/config.c 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/config.c 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/config.c 2008-06-29 01:12:36.000000000 +0200
@@ -61,6 +61,7 @@
char *error_log_name;
char *access_log_name;
if (mime_types) {
Index: boa-0.94.13/src/alias.c
===================================================================
---- boa-0.94.13.orig/src/alias.c 2002-07-28 04:46:52.000000000 +0200
-+++ boa-0.94.13/src/alias.c 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/alias.c 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/alias.c 2008-06-29 01:12:36.000000000 +0200
@@ -213,6 +213,7 @@
uri_len = strlen(req->request_uri);
return 0;
Index: boa-0.94.13/src/globals.h
===================================================================
---- boa-0.94.13.orig/src/globals.h 2002-07-24 05:03:59.000000000 +0200
-+++ boa-0.94.13/src/globals.h 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/globals.h 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/globals.h 2008-06-29 01:12:36.000000000 +0200
@@ -47,6 +47,7 @@
struct request { /* pending requests */
int fd; /* client's socket fd */
char *path_translated; /* env variable */
Index: boa-0.94.13/src/read.c
===================================================================
---- boa-0.94.13.orig/src/read.c 2002-03-18 02:53:48.000000000 +0100
-+++ boa-0.94.13/src/read.c 2008-06-15 23:21:11.000000000 +0200
+--- boa-0.94.13.orig/src/read.c 2008-06-29 01:11:52.000000000 +0200
++++ boa-0.94.13/src/read.c 2008-06-29 01:12:36.000000000 +0200
@@ -338,8 +338,11 @@
if (bytes_to_write == 0) { /* nothing left in buffer to write */
Index: boa-0.94.13/src/boa-plugin.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ boa-0.94.13/src/boa-plugin.h 2008-06-15 23:21:11.000000000 +0200
++++ boa-0.94.13/src/boa-plugin.h 2008-06-29 01:12:36.000000000 +0200
@@ -0,0 +1,67 @@
+#ifndef _HTTPD_PLUGIN_H__
+#define _HTTPD_PLUGIN_H__