[package] do not stall rcS start because of ddns-scripts init (#7109)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Apr 2010 20:51:41 +0000 (20:51 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Apr 2010 20:51:41 +0000 (20:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@20812 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh

index 3811865..930e60e 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 82f01ca..a5c44d7 100644 (file)
@@ -28,7 +28,7 @@ load_all_config_options()
        # after we're done with it.  For reference
        # the $1 variable is the name of the option
        # and $2 is the name of the section
-       config_cb() 
+       config_cb()
        {
                if [ ."$2" = ."$section_id" ]; then
                        option_cb()
@@ -89,7 +89,7 @@ get_current_ip()
                                current_ip=$(echo $( wget -O - $addr 2>/dev/null) | grep -o "$ip_regex")
                        fi
                done
-               
+
                #here we hard-code the dyndns checkip url in case no url was specified
                if [ -z "$current_ip" ]
                then
@@ -120,6 +120,6 @@ start_daemon_for_all_ddns_sections()
 
        for section in $SECTIONS
        do
-               /usr/lib/ddns/dynamic_dns_updater.sh $section 0&
+               /usr/lib/ddns/dynamic_dns_updater.sh $section 0 > /dev/null 2>&1 &
        done
 }