packages/taskwarrior: command line task manager
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Mar 2012 19:41:23 +0000 (19:41 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Mar 2012 19:41:23 +0000 (19:41 +0000)
Signed-off-by: Xiangfu <xiangfu.z@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30932 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/taskwarrior/Makefile [new file with mode: 0644]

diff --git a/utils/taskwarrior/Makefile b/utils/taskwarrior/Makefile
new file mode 100644 (file)
index 0000000..29af51e
--- /dev/null
@@ -0,0 +1,36 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+include $(TOPDIR)/rules.mk
+PKG_NAME:=taskwarrior
+PKG_VERSION:=1.9.4
+PKG_SOURCE:=task-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.taskwarrior.org/download/
+PKG_BUILD_DIR:=$(BUILD_DIR)/task-$(PKG_VERSION)
+
+PKG_RELEASE:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/taskwarrior
+       MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
+       TITLE:=Taskwarrior - command line task manager
+       SECTION:=utils
+       CATEGORY:=Utilities
+       DEPENDS:=+libncurses
+       URL:=http://taskwarrior.org/projects/show/taskwarrior
+endef
+
+define Package/taskwarrior/description
+       Taskwarrior is an ambitious project to supercharge task with an interactive interface, GTD features, color themes, data synch, dependencies,
+       custom reports, charts, and Lua plugins, all while our international team provides excellent support!
+endef
+
+define Package/taskwarrior/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/task $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,taskwarrior))