packages/cmdpad: use new service wrapper
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:49:29 +0000 (23:49 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:49:29 +0000 (23:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28930 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/cmdpad/Makefile
utils/cmdpad/files/cmdpad.init

index 18bdb8b..f2d11c2 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmdpad
 PKG_VERSION:=0.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/cmdpad
index c6f3577..f612033 100644 (file)
@@ -1,12 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
+
 START=93
 
+SSD_DAEMONIZE=1
+
 start() {
-    /usr/sbin/cmdpad --quiet > /dev/null &
+       service_start /usr/sbin/cmdpad --quiet
 }
-                                                       
+
 stop() {
-    killall cmdpad
+       service_stop /usr/sbin/cmdpad
 }
-                                                                                       
\ No newline at end of file