[Packages] net/rtorrent:
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Dec 2007 19:10:06 +0000 (19:10 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Dec 2007 19:10:06 +0000 (19:10 +0000)
 * Add missing libncurses dependency
 * Cleanup Makefile

git-svn-id: svn://svn.openwrt.org/openwrt/packages@10029 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rtorrent/Makefile

index 7d9a03d..1b2faf7 100644 (file)
@@ -26,14 +26,14 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent
+  DEPENDS:=+libcurl +libtorrent +libncurses
 endef
 
 define Package/rtorrent/description
- rTorrent is a BitTorrent client for ncurses, using the libtorrent library. 
- The client and library are written in C++ with emphasis on speed and 
- efficiency, while delivering equivalent features to those found in GUI 
- based clients in an ncurses client.
+       rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
+       The client and library are written in C++ with emphasis on speed and
+       efficiency, while delivering equivalent features to those found in GUI
      based clients in an ncurses client.
 endef
 
 CONFIGURE_ARGS+= \
@@ -46,13 +46,9 @@ CONFIGURE_VARS += \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
        LIBS="-lm" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
 define Package/rtorrent/install        
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/rtorrent $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rtorrent))