fix xtables-addons compile on non-linux systems
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jul 2009 13:55:18 +0000 (13:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jul 2009 13:55:18 +0000 (13:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16810 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xtables-addons/patches/001-no_depmod.patch
net/xtables-addons/patches/002-portability.patch [new file with mode: 0644]

index 417c139..be5d4ca 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN xtables-addons-1.17/Makefile.in xtables-addons-1.17.new/Makefile.in
---- xtables-addons-1.17/Makefile.in    2009-06-16 16:26:56.000000000 +0200
-+++ xtables-addons-1.17.new/Makefile.in        2009-06-18 15:24:34.000000000 +0200
-@@ -748,7 +748,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -748,7 +748,7 @@ install-dvi: install-dvi-recursive
  
  install-dvi-am:
  
diff --git a/net/xtables-addons/patches/002-portability.patch b/net/xtables-addons/patches/002-portability.patch
new file mode 100644 (file)
index 0000000..acd854d
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/extensions/GNUmakefile.in
++++ b/extensions/GNUmakefile.in
+@@ -2,8 +2,8 @@
+ top_srcdir      := @top_srcdir@
+ srcdir          := @srcdir@
+-abstop_srcdir   := $(shell readlink -f ${top_srcdir})
+-abssrcdir       := $(shell readlink -f ${srcdir})
++abstop_srcdir   := $(shell cd ${top_srcdir} && pwd)
++abssrcdir       := $(shell cd ${srcdir} && pwd)
+ ifeq (${abstop_srcdir},)
+ $(error Path resolution of ${top_srcdir} failed)
+--- a/extensions/ipset/GNUmakefile.in
++++ b/extensions/ipset/GNUmakefile.in
+@@ -3,8 +3,8 @@
+ top_srcdir      := @top_srcdir@
+ srcdir          := @srcdir@
+ datarootdir     := @datarootdir@
+-abstop_srcdir   := $(shell readlink -f ${top_srcdir})
+-abssrcdir       := $(shell readlink -f ${srcdir})
++abstop_srcdir   := $(shell cd ${top_srcdir} && pwd)
++abssrcdir       := $(shell cd ${srcdir} && pwd)
+ ifeq (${abstop_srcdir},)
+ $(error Path resolution of ${top_srcdir} failed)