maemo-kexec: Rename script to bootmaemo.
[packages.git] / utils / wx200d / Makefile
index 6dde919..c33d071 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/wx200d
 PKG_MD5SUM:=0f90c099dddcdd46ac568d707822ec4c
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,22 +24,18 @@ define Package/wx200d
   CATEGORY:=Utilities
   DEPENDS:=+libpq
   TITLE:=weather station data collector
-  DESCRIPTION:=\
-       wx200d is a weather station data collector and server daemon \\\
-       for the WX200, WM918, WMR918 and WMR968 weather station \\\
-       hardware.
   URL:=http://wx200d.sourceforge.net/
 endef
 
-# uses GNU configure
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/wx200d/description
+       wx200d is a weather station data collector and server daemon 
+       for the WX200, WM918, WMR918 and WMR968 weather station 
+       hardware.
 endef
 
-define Package/wx200d/install  
+# uses GNU configure
+
+define Package/wx200d/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/wx200 \
                $(PKG_INSTALL_DIR)/usr/bin/wxstdout \