nuke $Id$ in /packages as well
[packages.git] / utils / vim / Makefile
index 191018f..31ac7cd 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vim
 PKG_VERSION:=7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
@@ -30,22 +29,22 @@ define Package/vim/Default
 endef
 
 define Package/vim
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (Tiny)
 endef
 
 define Package/vim-full
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (Normal)
 endef
 
 define Package/vim-runtime
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (runtime files)
 endef
 
 define Package/vim-help
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (help files)
 endef
 
@@ -155,26 +154,6 @@ define Package/vim-help/install
        tar -C $(1) -xzf $(PKG_BUILD_DIR)/docs.tgz 
 endef
 
-define Package/vim-full/postinst
-#!/bin/sh
-  if [ $${IPKG_INSTROOT} != / ]
-  then
-    if [ -d /usr/share/ ]
-      ln -s $${IPKG_INSTROOT}/usr/share/vim/ /usr/share/
-    fi
-  fi
-endef
-
-define Package/vim/postinst
-#!/bin/sh
-  if [ $${IPKG_INSTROOT} != / ]
-  then
-    if [ -d /usr/share/ ]
-      ln -s $${IPKG_INSTROOT}/usr/share/vim/vimrc /usr/share/vim/vimrc
-    fi
-  fi
-endef
-
 $(eval $(call BuildPackage,vim))
 $(eval $(call BuildPackage,vim-full))
 $(eval $(call BuildPackage,vim-runtime))