cyrus-sasl: update to version 2.1.23.
[packages.git] / utils / unzip / Makefile
index ed338dc..f012816 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$ 
 
 include $(TOPDIR)/rules.mk
 
@@ -16,18 +15,16 @@ PKG_SOURCE:=$(PKG_NAME)552.zip
 PKG_SOURCE_URL:=@SF/infozip
 PKG_MD5SUM:=3d55b4e7375c3d0b81feca52dc0e4d48
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
-
 include $(INCLUDE_DIR)/package.mk
 
+PKG_UNPACK=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
+
 define Package/unzip
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=
   TITLE:=De-archiver for .zip files
-  URL:=http://infozip.sourceforge.net/Zip.html
+  URL:=http://infozip.sourceforge.net/UnZip.html
   SUBMENU:=compression
 endef
 
@@ -46,8 +43,8 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CF="$(TARGET_CFLAGS) -O -I$(STAGING_DIR)/usr/include -I. -DUNIX" \
-               LD="$(TARGET_CC) -L$(STAGING_DIR)/usr/lib" \
+               CF="$(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX" \
+               LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
                install
 endef