[packages] testusb: new package, can be used to perform various tests with use of...
[packages.git] / utils / testusb / Makefile
diff --git a/utils/testusb/Makefile b/utils/testusb/Makefile
new file mode 100644 (file)
index 0000000..542ef44
--- /dev/null
@@ -0,0 +1,45 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=testusb
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DEPENDS := libpthread
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/testusb
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6 @DEVEL +libpthread
+  TITLE:=USB testing utility
+  URL:=http://www.linux-usb.org/usbtest/testusb.c
+endef
+
+define Package/testusb/description
+       This tool can be used to perform various tests with use of the usbtest driver. 
+endef
+
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+       $(TARGET_CC) $(TARGET_CFLAGS) -Os -lpthread $(PKG_BUILD_DIR)/testusb.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+endef
+
+define Package/testusb/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/testusb $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,testusb))