[packages] added tcsh: Enhanced Berkeley UNIX C shell
[packages.git] / utils / tcsh / patches / 001-gethost
diff --git a/utils/tcsh/patches/001-gethost b/utils/tcsh/patches/001-gethost
new file mode 100644 (file)
index 0000000..62342e2
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -365,7 +365,7 @@
+ gethost:  gethost.c sh.err.h tc.const.h sh.h
+       rm -f gethost
+-      ${CC} -o gethost ${LDFLAGS} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
++      gcc -o gethost -g -O2 -I. -I. -D_PATH_TCSHELL='"/usr/local/bin/tcsh"' $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
+ tc.defs.c:    gethost host.defs
+       @rm -f $@.tmp