packages/mc: remove trailing whitespace
[packages.git] / utils / strace / Makefile
index 9528245..f87a503 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,30 +9,21 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_RELEASE:=3
-
-OLD_KERNEL=$(findstring y,$(foreach v,21 25,$(CONFIG_LINUX_2_6_$(v))))
-ifneq ($(OLD_KERNEL),)
-  PKG_VERSION:=4.5.16
-  PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
-  PATCH_DIR:=patches-4.5.16
-else
-  PKG_VERSION:=4.5.19
-  PKG_MD5SUM:=2415e435d61e40315a298c80aced0cda
-endif
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_VERSION:=4.7
+PKG_RELEASE:=1
+PKG_MD5SUM:=6054c3880a00c6703f83b57f15e04642
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
-PKG_FIXUP = libtool
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYRIGHT
 
-include $(INCLUDE_DIR)/package.mk
-
-CONFIGURE_VARS += \
-       ac_cv_header_linux_netlink_h=yes
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
-TARGET_CFLAGS += \
-       -I$(LINUX_DIR)/include
+include $(INCLUDE_DIR)/package.mk
 
 define Package/strace
   SECTION:=utils
@@ -46,9 +37,17 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
 system calls a program makes while it is running.
 endef
 
+# needed when compiling against Linux 2.4
 CONFIGURE_VARS += \
        ac_cv_header_linux_netlink_h=yes
 
+ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
+endif
+
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
+
 define Package/strace/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/