[package] add cgilib libtool fix from #5538
[packages.git] / utils / strace / Makefile
index 828a121..2019acd 100644 (file)
@@ -4,17 +4,24 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
+
+OLD_KERNEL=$(findstring y,$(foreach v,23 24 25 26,$(CONFIG_LINUX_2_6_$(v))))
+ifneq ($(OLD_KERNEL),)
+  PKG_VERSION:=4.5.16
+  PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
+  PATCH_DIR:=patches-4.5.16
+else
+  PKG_VERSION:=4.5.18
+  PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
+endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
 
 PKG_FIXUP = libtool