Add uci init script and config file.
[packages.git] / utils / smartmontools / Makefile
index 7ddab45..574894c 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.37
-PKG_RELEASE:=2
+PKG_VERSION:=5.38
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=a282846532ecbd6b4a28072373b3a70b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,9 +27,9 @@ define Package/smartmontools
 endef
 
 define Package/smartmontools/description
-       smartmontools contains utility programs (smartctl, smartd) to 
-       control/monitor storage systems using the Self-Monitoring, Analysis 
-       and Reporting Technology System (S.M.A.R.T.) built into most modern 
+       smartmontools contains utility programs (smartctl, smartd) to
+       control/monitor storage systems using the Self-Monitoring, Analysis
+       and Reporting Technology System (S.M.A.R.T.) built into most modern
        ATA and SCSI disks. It is derived from smartsuite.
 endef
 
@@ -61,7 +58,3 @@ define Package/smartmontools/install
 endef
 
 $(eval $(call BuildPackage,smartmontools))
-
-$(eval $(call RequireCommand,automake-1.9, \
-       $(PKG_NAME) requires automake 1.9 or compatible. \
-))