[packages] miniupnpd: Bump version to 1.5
[packages.git] / utils / setserial / Makefile
index 2d3d18b..c529f1f 100644 (file)
@@ -1,10 +1,9 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,9 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/setserial
 PKG_MD5SUM:=c4867d72c41564318e0107745eb7a0f2
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,27 +21,30 @@ define Package/setserial
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Serial port configuration utility
-  DESCRIPTION:=\
-       setserial  is a program designed to set and/or report the \\\
-       configuration information associated with a serial port. This \\\
-       information  includes what I/O port and IRQ a particular \\\
-       serial port is using, and whether or not the break key should \\\
-       be interpreted as the Secure Attention Key, and so on.
   URL:=http://setserial.sourceforge.net/
+  SUBMENU:=Terminal
+endef
+
+define Package/setserial/description
+       setserial is a program designed to set and/or report the 
+       configuration information associated with a serial port. This 
+       information includes what I/O port and IRQ a particular 
+       serial port is using, and whether or not the break key should 
+       be interpreted as the Secure Attention Key, and so on.
 endef
 
 # uses GNU configure
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               all
+               setserial
 endef
 
 define Package/setserial/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/setserial $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/serial.init $(1)/etc/init.d/setserial
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/setserial $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/serial.init $(1)/etc/init.d/setserial
 endef
 
 $(eval $(call BuildPackage,setserial))