screen: Update to version 4.2.1
[packages.git] / utils / screen / patches / 110-do_not_add_srcdir_to_include_path.patch
diff --git a/utils/screen/patches/110-do_not_add_srcdir_to_include_path.patch b/utils/screen/patches/110-do_not_add_srcdir_to_include_path.patch
new file mode 100644 (file)
index 0000000..50d00b8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -79,7 +79,7 @@ screen: $(OFILES)
+       $(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
+ .c.o:
+-      $(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(CPPFLAGS) $(DEFS) \
++      $(CC) -c $(M_CFLAGS) $(CPPFLAGS) $(DEFS) \
+           $(OPTIONS) $(CFLAGS) $<
+ install_bin: .version screen