use Build/Configure/Default macro, Makefile cleanup
[packages.git] / utils / screen / Makefile
index 6b1b5ac..d51e3e5 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=screen
 PKG_VERSION:=4.0.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=ed68ea9b43d9fba0972cb017a24940a1
 
-PKG_SOURCE_URL:=@GNU/screen
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/screen
+PKG_MD5SUM:=ed68ea9b43d9fba0972cb017a24940a1
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -27,41 +27,13 @@ define Package/screen
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=Full-screen terminal window manager
-  DESCRIPTION:=Screen is a full-screen window manager that multiplexes a physical\\\
-       terminal between several processes, typically interactive shells.\\\
+  DESCRIPTION:=\
+       Screen is a full-screen window manager that multiplexes a physical\\\
+       terminal between several processes, typically interactive shells.
   URL:=http://www.gnu.org/software/screen/
 endef
 
-define Build/Configure 
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --disable-static \
-       );
-endef
+# uses GNU configure
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)