massive Makefile cleanup, add missing 'svn:keywords' property
[packages.git] / utils / sane-backends / Makefile
index da2099e..e1597f8 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=sane-backends
 PKG_VERSION:=1.0.17
 PKG_RELEASE:=1
-PKG_MD5SUM:=b51c10da8a81a04e1bae88c9e6556df2
 
-PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_MD5SUM:=b51c10da8a81a04e1bae88c9e6556df2
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,7 +26,8 @@ define Package/sane-backends
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Scanner Access Now Easy (backends)
-  DESCRIPTION:=SANE (Scanner Access Now Easy) is a universal scanner interface.
+  DESCRIPTION:=\
+       SANE (Scanner Access Now Easy) is a universal scanner interface.
   URL:=http://www.sane-project.org
 endef
 
@@ -35,20 +36,18 @@ define Package/sane-backends/conffiles
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                       --disable-static \
-                       --disable-ipv6 \
-                       --disable-translations \
-                       --without-gphoto2 \
-                       --disable-debug)
+       $(call Build/Configure/Default, \
+               --disable-ipv6 \
+               --disable-translations \
+               --without-gphoto2 \
+               --disable-debug \
+       )
 endef
 
 define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
+               all install
 endef
 
 define Package/sane-backends/install