add powertop, thanks Raphael HUCK
[packages.git] / utils / powertop / Makefile
diff --git a/utils/powertop/Makefile b/utils/powertop/Makefile
new file mode 100644 (file)
index 0000000..6fe8095
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=powertop
+PKG_VERSION:=1.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.lesswatts.org/projects/powertop/download/
+PKG_MD5SUM:=3498f5983c683c3a57dce7379a722082
+
+PKG_INSTALL:=1
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/powertop
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=PowerTOP
+  DEPENDS:=+libncurses +libgcc
+  KCONFIG:=CONFIG_DEBUG_KERNEL=y CONFIG_TIMER_STATS=y
+  URL:=http://www.lesswatts.org
+endef
+
+define Package/powertop/description
+PowerTOP is a Linux tool that helps you find those programs that are misbehaving
+while your computer is idle.
+endef
+
+define Package/powertop/install
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+$(eval $(call BuildPackage,powertop))
+